"Invalid API Key" error message when trying to use the Connector

  • 1
  • Problem
  • Updated 2 years ago
I have completed the setup of the connector according to the administrators guide but every time I try and use the connector I receive an "Invalid API Key" error message. This happens with all users in Confluence. I have triple checked that the key matches what Google generated and even tried generating a new key in the Google API but no luck. Please advise/help.
Photo of Josh Hanft

Josh Hanft

  • 3 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Suresh Mathusuthanan

Suresh Mathusuthanan, Alum

  • 117 Posts
  • 9 Reply Likes
Hi Josh,

It would be great if you can share with us the following :
  • Confluence Google Connector version
  • Confluence version
  • Screenshot of the affected page

Thank you.

Regards,
Suresh  
(Edited)
Photo of Josh Hanft

Josh Hanft

  • 3 Posts
  • 0 Reply Likes
Hi Suresh,

Here are the details:
-Connector for Google Drive and Confluence version: 2.0.0
-Confluence version: 6.0.0-OD-2016.10.0-1054
-Screenshot of the error:  

Thanks for your help.

Regards,
Josh
Photo of Suresh Mathusuthanan

Suresh Mathusuthanan, Alum

  • 117 Posts
  • 9 Reply Likes
Hi Josh,

I would like to confirm if you have enabled the Picker API in Google cloud platform ?

If you have not, please refer to Step 2 of this documentation to enable your Google Picker API.

Thank you.

Regards,
Suresh
Photo of Josh Hanft

Josh Hanft

  • 3 Posts
  • 0 Reply Likes
Hi Suresh, 

That indeed was the issue. I enabled the picker and now it is working as expected. I apologize for missing that step. Thanks for all your help!!!

Regards,
Josh
Photo of Suresh Mathusuthanan

Suresh Mathusuthanan, Alum

  • 117 Posts
  • 9 Reply Likes
Hi Josh,

Glad to hear that. You're welcome. 

If there are any further questions or inquiries, feel free to contact us.

Have a nice day!

Cheers,
Suresh