Cannot Install Composition Plugin into Confluence 5.8.18

  • 1
  • Problem
  • Updated 2 years ago
The Composition plugin appears to upload but seems to hang on the install part and never completes. I can provide logs but at present, all that I have installed an updated UPM. Every other plugin has been removed from the system. I've tried with UPM 2.20.5, 2.20.7. I've tried with 5.1.0, 5.1.1. I don't see anything in the logfile that gives any indication that: 1) the UPM was attempting to install the plugin, or 2) that the UPM was having issues installing the plugin.

So, what do you want for analysis (logs - what else?) - this has been a major problem since starting the upgrade to 5.8.18 and every environment has had issues that I had normally been able to get around. But I'm at a complete stopping point - blocked, and this prevents me from upgrading Production.

Steve Hadfield
Photo of shadmansmusings

shadmansmusings

  • 58 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 1
Photo of shadmansmusings

shadmansmusings

  • 58 Posts
  • 2 Reply Likes
Atlassian tells me that its been reported to them (or their findings) that Composition sometimes takes up to 12 hours to install! Is that true?
Photo of Mervyn Toh

Mervyn Toh, Alum

  • 117 Posts
  • 7 Reply Likes
Hi,

The issue that you're facing currently is mentioned on our documentation. We had prior issues similar to this due to the add-on being installed into the large sized instance.

The installation usually runs some SQL statements to check on certain information that extends the duration of the installation. Hence, the larger the instance is, the longer it is to install the add-on on the instance.

Thank you.
Photo of Itweb

Itweb

  • 1 Post
  • 0 Reply Likes
Hi,

The same with Confluence 5.7.4. I restarted to rollback...
Photo of Nurhana Ziana Bt. Hanafi

Nurhana Ziana Bt. Hanafi, Employee

  • 3500 Posts
  • 269 Reply Likes
Hello there,

Are you upgrading your Confluence? If yes, from which version?

Thanks&Regards,
Ziana