Cannot use 'as' value in expanding-reporter for filtering

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
I have created a report for the purpose of finding all the pages with links which will be invalid once published to the external website.  My problem is that the {expanding-reporter} will not let me use  the 'As' parameter for filtering.  In the following example, I would like to use the {boolean-filter} to only list the links which  expanded:Outlink > link:is external  is 'true'.   I would also like to use {text filtering} to narrow down the results; but I cannot filter with expanded:Outlink > link:url either.  Have also tried using the filters with Outlink. But in all cases, when I select the Required checkbox within the filter, the report is blank. I interpret this to mean that it cannot find the variables at all.

I'm hoping somebody can clue me in on what I'm doing wrong or an alternative way to code this.

The following code will print the report without the filtering taking effect:
(Replace ALLDOC with space of your choice)

{report-table}
  {expanding-reporter:content:outgoing links|as = Outlink}
    {content-reporter:spaces=ALLDOC|types=page}
    {content-reporter}
    {boolean-filter:Outlink > link:is external|value=true}
  {expanding-reporter}
  {report-column:title=Page}
    {report-info:expanded:item|link=true}
  {report-column}
  {report-column:title=URL}
    {report-info:expanded:Outlink > link:url}
  {report-column}
  {report-column:title=External}
    {report-info:expanded:Outlink > link:is external}
  {report-column}
  {report-column:title=Destination}
    {report-info:expanded:Outlink > link:destination|link=true}
  {report-column}
{report-table}

Confluence 4.3.7
Reporting 4.1.0

Thanks in advance,
Jason
Photo of Jason W

Jason W

  • 4 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Jason W

Jason W

  • 4 Posts
  • 0 Reply Likes
I have upgraded our sandbox instance to Confluence 5.9.9 which uses Reporting 6.2.0; and I get the same problem.

Thx,
Jason
Photo of Nurhana Ziana Bt. Hanafi

Nurhana Ziana Bt. Hanafi, Employee

  • 3500 Posts
  • 269 Reply Likes
Hello Jason,
 {expanding-reporter:content:outgoing links|as = Outlink}
I suspect it is caused by white space in between =, kindly please try below:
{expanding-reporter:content:outgoing links|as=Outlink}

Thanks&Regards,
Ziana
Photo of Jason W

Jason W

  • 4 Posts
  • 0 Reply Likes
I'm afraid that didn't help. The code is being created by the macro, so I went into source-edit mode and took all spaces out. But the filter still does not take effect.
I've included the source code on the support ticket I created.

Thx,
Jason