Cannot use Atlassian Marketplace key on older Scaffolding

  • 1
  • Problem
  • Updated 2 years ago
The KB article https://docs.servicerocket.com/pages/viewpage.action?pageId=5965911 says Scaffolding 6.3.0 implemented dual licensing.  We are using an older Confluence, 4.2.13, and installing Scaffolding properly brings in the appropriate version 4.6.5 .  We bought our Scaffolding, Reporting, and Composition through Atlassian Marketplace, yet our Atlassian-form license keys (starting "AAA..." ) won't install on Reporting or Scaffolding (the "Input length must be multiple of 8 when decrypting with padded cipher" error).  How can I get an equivalent ServiceRocket license key?

The Reporting add-in behaves the same - installation properly matches version 4.1.0 with my Confluence version, so the Atlassian key won't install.

Composition took the Atlassian key fine, so it is working.

We cannot update the base Confluence now - having to maintain compatibility with someone else's old install.
Photo of Jake

Jake

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Mervyn Toh

Mervyn Toh, Alum

  • 117 Posts
  • 7 Reply Likes
Hi Jake,

Any version of Scaffolding older than 6.3.0 only accepts Atlassian's license key. ServiceRocket license key can only be used with add-ons that supports dual licensing - for Scaffolding, 6.3.0 and later. Since you're using and can only use an Atlassian license key, raising this issue to Atlassian Support would be the best solution, as they might be able to provide you with a new license key.

Besides, it is recommended to upgrade your Confluence to a later version according to the Atlassian EOL Policy, as Atlassian only provides support to versions that are listed in the EOL Policy, and this applies to our add-ons as well.

Thank you.