Confluence macro usage doesn't work

  • 2
  • Problem
  • Updated 2 years ago
Hi there,
we recently upgrade our Confluence to 5.10.2.
On the new "macro usage page" (BASE-URL/admin/pluginusage.action) we always receive a "page not found".

Log says always:
 ERROR [ajp-nio-8009-exec-6] [atlassian.confluence.servlet.ConfluenceServletDispatcher] serviceAction There is no Action mapped for namespace /admin and action name pluginusage
 -- referer: https://BASE-URL/admin/viewgeneralconfig.action | url: /admin/pluginusage.action | traceId: 644f9cffec6d744b 
=> https://confluence.atlassian.com/confkb/confluence-states-there-is-no-action-mapped-for-namespace-x-...
But this doesn't help and with Atlassian Support we found the main cause.

I disabled the Scaffolding-Plugin and the page works as expected.
With re-enabled Plugin the page failed again so that is a Scaffolding-Problem.

Is this a know Bug?

Kind regards
André
Photo of Andre Lehmann

Andre Lehmann

  • 77 Posts
  • 3 Reply Likes

Posted 2 years ago

  • 2
Photo of Suresh Mathusuthanan

Suresh Mathusuthanan, Alum

  • 117 Posts
  • 9 Reply Likes
Hi André,

We are sorry that you're having this issue.

I've managed to replicate this on our instance, and confirmed this as a bug with the developers. I'll proceed to raise a bug ticket on this issue with our developers. I'll inform you when there are any updates, or details needed on your issue.

If there are any further questions or inquires, feel free to let us know.

Thanks.

Regards,
Suresh
Photo of Clement Wong

Clement Wong

  • 7 Posts
  • 1 Reply Like
Scaffolding v8.6.2 is still causing the macro usage page to break.
Photo of Suresh Mathusuthanan

Suresh Mathusuthanan, Alum

  • 117 Posts
  • 9 Reply Likes
Hi Clement, 

We have responded to you via our support channel.

Thank you.

Regards,
Suresh
(Edited)
Photo of Matthias Born

Matthias Born

  • 24 Posts
  • 0 Reply Likes
I'm interested in to.
Please make public statements about the status.
Regards,
Matthias
Photo of Suresh Mathusuthanan

Suresh Mathusuthanan, Alum

  • 117 Posts
  • 9 Reply Likes
Hi Mathias,

As of now, the developers are looking into the code of the Scaffolding plugin to find out the changes made, and possibly to be able to find the root cause of this issue.

We will update you soon.

Thank you.
Photo of Suresh Mathusuthanan

Suresh Mathusuthanan, Alum

  • 117 Posts
  • 9 Reply Likes
Hi Andre, Clement and Mathias,

Scaffolding 8.7.0 should contain the fix to your issue. 

You can refer our announcement here in-regards the fix. 

Thank you.

Regards,
Suresh
Photo of Matthias Born

Matthias Born

  • 24 Posts
  • 0 Reply Likes
Works fine. Thank you!