local-reporter gives empty content:body

  • 1
  • Problem
  • Updated 2 years ago
Reporting 6.5.1 (also tried 6.5.0,6.4.8) with confluence 6.0.1.
Using  local-reporter to report child pages. page:body is always empty. (Other content supplier such as page:title and page:excerpt are OK).

I really appreciate if you can fix this problem or tell me a workaround.

Storage format are as follows:
<p>&nbsp;</p> <p>&nbsp;<ac:structured-macro ac:macro-id="42999a25-b440-4c81-a29e-01f24af29e8b" ac:name="report-block" ac:schema-version="1"><ac:parameter ac:name="atlassian-macro-output-type">INLINE</ac:parameter><ac:rich-text-body><ac:structured-macro ac:macro-id="d5a555a4-6779-4d8e-b3f4-269569855876" ac:name="local-reporter" ac:schema-version="1"><ac:parameter ac:name="source">@self</ac:parameter><ac:parameter ac:name="">page:sorted children</ac:parameter><ac:rich-text-body> <p><ac:structured-macro ac:macro-id="e06c5452-e119-4742-b7fc-0bace46bbd38" ac:name="text-filter" ac:schema-version="1"><ac:parameter ac:name="required">true</ac:parameter><ac:parameter ac:name="">content:body</ac:parameter></ac:structured-macro></p></ac:rich-text-body></ac:structured-macro> <p>&nbsp;</p> <p>&nbsp;</p> <p>&nbsp;</p><ac:structured-macro ac:macro-id="993ab8e3-4ad6-464a-821b-489bfce157d0" ac:name="report-body" ac:schema-version="1"><ac:rich-text-body> <h2><ac:structured-macro ac:macro-id="cc653777-51ee-41ca-96c6-4d290e67250b" ac:name="report-info" ac:schema-version="1"><ac:parameter ac:name="link">true</ac:parameter><ac:parameter ac:name="">content:title</ac:parameter></ac:structured-macro></h2> <p><ac:structured-macro ac:macro-id="8b223e9e-29d6-4e34-8897-ff1d43bb9223" ac:name="report-info" ac:schema-version="1"><ac:parameter ac:name="render">richtext</ac:parameter><ac:parameter ac:name="atlassian-macro-output-type">INLINE</ac:parameter><ac:parameter ac:name="">content:body</ac:parameter></ac:structured-macro></p></ac:rich-text-body></ac:structured-macro></ac:rich-text-body></ac:structured-macro>&nbsp;</p> <p>&nbsp;</p>
Photo of Xiaoyi

Xiaoyi

  • 5 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Xiaoyi

Xiaoyi

  • 5 Posts
  • 0 Reply Likes
It's worth to mention that the "content-reporter" works fine (i.e. content:body is non-empty).
Photo of Mervyn Toh

Mervyn Toh, Alum

  • 117 Posts
  • 7 Reply Likes
Hi Xioyi,

Thanks for raising this up.

I've managed to replicate this, and I've raised this issue to the project team for further investigation. I shall get back to you if there is any updates from the project team.

Thank you.
Photo of Xiaoyi

Xiaoyi

  • 5 Posts
  • 0 Reply Likes
I really appreciate if you can fix this problem or tell me a workaround, because this is definitely a blocking issue.  When will you fix this issue? 
Photo of Xiaoyi

Xiaoyi

  • 5 Posts
  • 0 Reply Likes
Is there any progress? Since this is a blocking issue, we can not see our page properly and a workaround is desired before you resolve the issue completely.
Photo of Xiaoyi

Xiaoyi

  • 5 Posts
  • 0 Reply Likes
I tried the new release of Reporting 6.5.2. This bug is not fixed yet.  It is really disappointing  got no fix, no update and no response. 
Photo of Nurhana Ziana Bt. Hanafi

Nurhana Ziana Bt. Hanafi, Employee

  • 3500 Posts
  • 269 Reply Likes
Hello Xiaoyi,

Can you try with content:body > body:text keychain, see if it helps?

Thanks&Regards,
Ziana