Mapping Key and Component/s fields to Salesforce

  • 2
  • Problem
  • Updated 2 years ago
I am using the ServiceRocket Salesforce.com Connector Plugin, v 5.5, and attempting to sync the standard Key and Component/s fields in JIRA to custom fields on the Idea object in Salesforce.  I am able to setup the mapping as below, however, when doing a push from JIRA, these fields are not being populated in Salesforce.  Within JIRA after doing the push, I am seeing the success message "Pushed changes successfully to Salesforce!" and there are no logs generated in the Connector Diagnostics. I have confirmed that the Salesforce used to authenticate the Connection has access to edit both the Idea object and the specific custom fields in Salesforce.  Other fields are syncing as expected so it appears to be an issue with these specific fields.  Any suggestions on what may be causing the issue?

Photo of Stephen

Stephen

  • 14 Posts
  • 1 Reply Like
  • confused

Posted 3 years ago

  • 2
Photo of Samuel Gatica

Samuel Gatica, Alum

  • 33 Posts
  • 2 Reply Likes
Hi,


Are you following any documentation?
What is the version of your Salesforce instance (Enterprise/Unlimited/Professional)?
What is the version of your JIRA instance?
What is the version of the Connector plugins?

ServiceRocket Core Connector - Plugin
ServiceRocket JIRA Connector - Plugin
ServiceRocket Salesforce.com Connector Plugin - Plugin

Thank you.

Regards,
Sam
Photo of Stephen

Stephen

  • 14 Posts
  • 1 Reply Like
Yes, I am following this documentation.

Salesforce edition = Performance
JIRA version = 1000.5.2
Salesforce & JIRA Cloud Connector version = 1.0.6-AC (currently in a trial period)
 
Photo of Samuel Gatica

Samuel Gatica, Alum

  • 33 Posts
  • 2 Reply Likes
Hi,

Can you please take a screenshoot from the Connection Configuration.

Thanks,
Sam
Photo of Stephen

Stephen

  • 14 Posts
  • 1 Reply Like
Hi Sam,

Here's a screenshot of that:
Photo of Samuel Gatica

Samuel Gatica, Alum

  • 33 Posts
  • 2 Reply Likes
Hi,

Can you please let us know the type of field is Jira Component and JIRA Ticket Number in Salesforce?

Thanks,
Sam
Photo of Stephen

Stephen

  • 14 Posts
  • 1 Reply Like
Hi Sam,

The type is 'Text' for both of these fields in Salesforce, both have a field limit of 100 characters.

Thanks
Photo of Samuel Gatica

Samuel Gatica, Alum

  • 33 Posts
  • 2 Reply Likes
HI,

Can you please delete Components/s from mapping and try again.

Thanks,
Sam
Photo of Stephen

Stephen

  • 14 Posts
  • 1 Reply Like
Hi Sam,

Removing Components/s from the mapping allowed the Key field to sync with Salesforce.  Is it accurate that the standard Components/s field cannot be synced with Salesforce? And that if it's included in the mapping, any mapped fields "under" it will also fail?

Thanks
Photo of Samuel Gatica

Samuel Gatica, Alum

  • 33 Posts
  • 2 Reply Likes
Hi,

Component/s cannot be map to a Text field-
Please refer to " JIRA Field Type to Salesforce Field Type Compatibility "

Regards,
Sam
Photo of Stephen

Stephen

  • 14 Posts
  • 1 Reply Like
Hi Sam,

Can you please let me know is the JIRA field type for the standard Components/s field?  With this I will be able to determine what I need to change the Salesforce field type to.

Thanks
Photo of Samuel Gatica

Samuel Gatica, Alum

  • 33 Posts
  • 2 Reply Likes
Hi,

JIRA field type for the standard Components/s field is a "Autocomplete Renderer" and can only be map with a multipicklist

Regards,
Sam
Photo of Stephen

Stephen

  • 14 Posts
  • 1 Reply Like
Hi Sam,

Thank you for that. Now that I've created a new multi-select picklist field in Salesforce, how do I "refresh" the Connector in JIRA to see this new field?  In the mapping it is not appearing.

Thanks
Photo of Samuel Gatica

Samuel Gatica, Alum

  • 33 Posts
  • 2 Reply Likes
Hi,

This may take a couple of minutes, you can clear the browser cache, and try again.

Regards,
Sam
Photo of Stephen

Stephen

  • 14 Posts
  • 1 Reply Like
Hi Sam,

It's been nearly 30 minutes and I have cleared my browser cache. I am still not seeing the new field appear.  Is there a way to force a "refresh"?

Thanks
Photo of Samuel Gatica

Samuel Gatica, Alum

  • 33 Posts
  • 2 Reply Likes
Hi,

We cache the fields per browser session, try to restart the browser (Make sure you Quit) and open the mapping fields page again.

Regards,
Sam
Photo of Stephen

Stephen

  • 14 Posts
  • 1 Reply Like
Hi Sam,

I was able to resolve this issue with a restart of my machine.

Thanks
Photo of Aidin Mahmoodi

Aidin Mahmoodi, Alum

  • 267 Posts
  • 6 Reply Likes
Hi Stephen,

Thank you for the feedback.

Glad to hear that it is working now!

Cheers,
Aidin