Page approval (version 2.2.4) bombs me with too many emails.

  • 1
  • Problem
  • Updated 2 years ago
Hi everyone, I have a problem with the page approval macro (version 2.2.4). It took a while until we got the notification working. However, right now it is literally bombing us with emails. The moment somebody loads the page an email confirmation is sent saying user X tries to register for approval. Nothing has been changed, nothing has been edited. The page was simply loaded. It does not really make sense. There is no way for me to disable that and make it send notifications ONLY when the page is actually approved. Additionally I would like to disable the feature that a user's approval disappears if the page was opened in edit mode. Hope you can help. It would be quite important and urgent for me and my team. Thanks a lot in advance!
Photo of Claudia

Claudia

  • 1 Post
  • 0 Reply Likes
  • frustrated and anxious

Posted 3 years ago

  • 1
Photo of Nurhana Ziana Bt. Hanafi

Nurhana Ziana Bt. Hanafi, Employee

  • 3500 Posts
  • 269 Reply Likes
Hello Claudia,

Perhaps could you try to choose the last option for Notified Actions row in Global Settings and see if it helps?

While for the other issue, page approval is actually works based on the page version changes. Once the version changed, the page will be automatically unapproved.

Hope this will clarify your doubts.


Thanks&Regards,
Ziana
Photo of David Wood

David Wood

  • 4 Posts
  • 0 Reply Likes
Hi, what was the solution on this ulitmately?
Photo of Nurhana Ziana Bt. Hanafi

Nurhana Ziana Bt. Hanafi, Employee

  • 3500 Posts
  • 269 Reply Likes
Hello David,

Have you tried the suggestion above? If it is not working for you, please provide us your Confluence and Page Approval version for our review.

Thanks&Regards,
Ziana
Photo of Martin Tippmann

Martin Tippmann

  • 3 Posts
  • 0 Reply Likes
Hi, I have the same problem -
Confluence 5.10.1 and Page Approval 4.1.0 

Notifications are Disabled and Mails are send out as soon as a user visits a page. 

The mails look like this (sorry for german the important part is the "User registered", I've added my translation in braces) 

I don't know how to stop this, everything is configured to not notify and as I've understood the plugin it should NEVER notify on just page visits. 

Mail starts here 
Subject: [confluence] Freigabe Benachrichtigung (approval notice) für <page name> in dem Bereich: <space name>

User registered: <user that JUST is visiting the site> 
xxx eingetragen für die Freigabe der Seite (signed up for approval of page) <page to be approved>Die Seite <page to be approved> wurde als freizugeben gesetzt. (page was set to be approved)
(Edited)
Photo of Jürgen Rudolph

Jürgen Rudolph

  • 2 Posts
  • 0 Reply Likes
Same problem here -
Confluence 5.9.7, Page Approval 4.1.0
Actually there are two problems. Here's how to reproduce them:

  1. Create a blank page and enter the following (as Markup):
    {pageapproval:notifiedusers=approved|notifyapprovals=true|notifiedactions=unapproval}

  2. Double-click it and enter your name as "User"

  3. Save the page (don't forget a title)

  4. Approve the page. You will now receive an e-mail saying the page needs to be approved. This is problem #1: You receive an unapproval message when approving a page. Change it to notifiedactions=approval leads to a changed e-mail body, but it is also initiated when clicking approve.

  5. Press F5 to reload the page. Each time you reload the page in the state "Approved" you will receive another e-mail. That is problem #2. However, you do not receive an e-mail when reloading the page in an unapproved state.
Photo of Suresh Mathusuthanan

Suresh Mathusuthanan, Alum

  • 117 Posts
  • 9 Reply Likes
Hi Jürgen,

Page Approval version 4.1.1 have been released, it should contain the fix to your issue. Please check the announcement on our ServiceRocket Community. 

You can update your Page Approval to the latest version. Let me know if this is working on your end.

Thank you.

Regards,
Suresh
Photo of David Wood

David Wood

  • 4 Posts
  • 0 Reply Likes
This seems to have resolved the issue for us.  Thank you!
Photo of Jürgen Rudolph

Jürgen Rudolph

  • 2 Posts
  • 0 Reply Likes
The update fixed the problem - thank you very much!