Reporting add-on - Error occurred while rendering report: null

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
Hello .. thank you in advance,

After upgrade, I got Error occurred while rendering report: null. 

I use Local Report macro to read data from child page, and it gives the error. Please see script in screenshot attached.  The error only happens when viewing page from anonymous user, if I log in as other users, the macro works fine.

It works fine when logged in.  Eg. it shows "John"

However, when accessing page as anonymous user.  It gives error.

From log file,
2016-03-13 23:08:53,609 ERROR [http-nio-8090-exec-1] [reporting.confluence.macro.AbstractReportingMacro] execute Error occurred while rendering report -- url: /display/WEB/Top+Page | userName: anonymous | action: viewpage | page: 34275331

Space Permission setting seems correct.

I'm running
- Scaffolding plugin version 8.1.0
- Reporting plugin version 6.1.1
- Confluence version 5.9.6
- Java VM seems ok
Photo of Pumin Wuvanich

Pumin Wuvanich

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Mervyn Toh

Mervyn Toh, Alum

  • 117 Posts
  • 7 Reply Likes
Hi Pumin,

Thanks for contacting us. Since you've send in a support ticket, we'll reply to your ticket on our support desk.

Thank you.
Photo of Steve Karam

Steve Karam

  • 1 Post
  • 0 Reply Likes
I'm getting the same issue: the report works for logged in users, not for anonymous users. What was the resolution for this? We're on Confluence 5.9.10 and Reporting 6.2.1.