Salesforce link not loading on Jira ticket page

  • 1
  • Problem
  • Updated 2 years ago
After I create a ticket going from Salesforce to Jira, while looking at the ticket from the Jira side the link back to the salesforce object doesn't load for my Campaign item (Screen Shot 1). It is loading for my Media Campaign ticket just fine (Screen Shot 2). I receive an error message at the top of the screen that says "Invalid Query". Not sure if there's anything from my side that I can do about this.












Photo of Jeremy Price

Jeremy Price

  • 11 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Adrien Low

Adrien Low, Alum

  • 85 Posts
  • 3 Reply Likes
Hello Jeremy,

It would be great if you could provide me with the following information:-
  1. JIRA -> Add-ons -> Left panel under Salesforce, click Connections -> Screenshot
  2. JIRA -> Add-ons -> Left panel under Salesforce, click Connections -> Your Connection -> Configure -> Full screenshot
  3. JIRA -> Add-ons -> Left panel under Salesforce, click Bindings -> Screenshot
  4. JIRA -> Add-ons -> Left panel under Salesforce, click Bindings -> Your Binding -> Mapping -> Screenshot
  5. JIRA -> Add-ons -> Left panel under Salesforce, click Bindings -> Your Binding -> Mapping -> Your Mapping Configuration -> Mappings -> Screenshot
Is this happening to JIRA Issues in the same project? If yes,can you try binding to another project and retry again.

Are you using a Custom Object in Salesforce? If so, have you followed this document? Please provide screenshots of your configurations.

Regards,
Adrien
Photo of Jeremy Price

Jeremy Price

  • 11 Posts
  • 0 Reply Likes
Attached are the screenshots in the exact order. This was working fine with the same configuration a few weeks ago. Yes, this is happening to JIRA issues in the same project. So I did what you suggested and tried it in another project and I receive the same error message. Also I did follow those steps in that documentation for mapping to a custom object other than a case object.










Photo of Adrien Low

Adrien Low, Alum

  • 85 Posts
  • 3 Reply Likes
Hello Jeremy,

It would be great if you can provide me with the following additional details:-
  1. JIRA -> Left panel under Salesforce, click Connections -> Your Connection -> Configure -> Campaign Item -> Fields -> Full screenshot (refer to below image)
  2. The field types of each field listed in the Fields screen
After opening up the Fields screen, remove each field one-by-one and then refreshing the JIRA Issue to see if the issue is resolved.

Regards,
Adrien