Trying to create a Jira issue and getting "An error occurred while processing your request. Kindly check the specified object type and ...."

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I've just installed the trial version of the connector and trying to get this set up.  When I select to create a Jira issue from Salesforce, I get the following error:

"An error occurred while processing your request. Kindly check the specified object type and ids of the request. Error: null"

Here is my button:

Button code = http://office.zoona.co.za/jira/plugins/servlet/customware/connector/issue/3/Case/create.action?id={!...

I then get this:



and when selecting "Create", I get the error:



I have set up minimal mappings:



We restarted Jira last night but no difference.  Any suggestions?
Photo of Bridgid

Bridgid

  • 7 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Bridgid

Bridgid

  • 7 Posts
  • 0 Reply Likes
Hi - can anyone help with this please?

Bridgid
Photo of Hashimi

Hashimi

  • 642 Posts
  • 40 Reply Likes
Hi Bridgid,

Sorry for the delay.
Which JIRA version and Connector version that you have?
How about connection test? it is pass?
Did you see any error in connector diagnostic or JIRA log?

Thanks
Hashimi
Photo of Bridgid

Bridgid

  • 7 Posts
  • 0 Reply Likes
Hi Hashimi,

Thanks for the feedback.  Responses as follows:

Which JIRA version and Connector version that you have?  Jira v 6.1.1 and Connector 5.4.2
How about connection test? it is pass? Yes
Did you see any error in connector diagnostic or JIRA log? Details below:



Bridgid
Photo of Bridgid

Bridgid

  • 7 Posts
  • 0 Reply Likes
Hi again Hashimi,

Do you have any feedback for me please?

Thanks

Bridgid
Photo of Hashimi

Hashimi

  • 642 Posts
  • 40 Reply Likes
Hi Bridgid,

I hope you are doing well and thanks for your co-operation during screen sharing session to solve the problem. Please let us know if you have others queries or problem.

Regards,
Hashimi
Photo of Pravendra Tomar

Pravendra Tomar

  • 1 Post
  • 0 Reply Likes
Can you please let me know what was the solution for the above issue? We are seeing the same issue in our setup.
Photo of Aidin Mahmoodi

Aidin Mahmoodi, Alum

  • 267 Posts
  • 6 Reply Likes
Hi Pravendra,

Please follow the instructions bellow to reconfigure the authentication:
  • JIRA > Connections > Edit > Manage Application Links
  • Configure Authentication > Disable
  • Configure Authentication > Re-configure (make sure to append Salesforce Security token)
  • Connections > test
Please let us know if this resolve your issue.

Cheers,
Aidin
Photo of Bridgid

Bridgid

  • 7 Posts
  • 0 Reply Likes
Hi Hashimi,

Thank you for your assistance on the call.  I do have another issue that I require assistance with - I have followed the steps here - https://docs.servicerocket.com/display/CFSJ/Viewing+Related+JIRA+Issues to view the related issues in Jira but I only see a blank area (see image).  Do you have any troubleshooting steps you could suggest please?


Thanks

Bridgid
Photo of Hashimi

Hashimi

  • 642 Posts
  • 40 Reply Likes
Hi Bridgid,

Please refer to the following knowledge base articles:
Thanks
Hashimi
Photo of Bridgid

Bridgid

  • 7 Posts
  • 0 Reply Likes
Hi - thanks for getting back to me.  I have already tried this but I have the same issue.  Please advise if there are any other possible fixes.

Bridgid
Photo of Bridgid

Bridgid

  • 7 Posts
  • 0 Reply Likes
Hi Hashimi,

Just following up on this - please advise re any other possible solutions or if we could have a screen sharing session?

Thanks

Bridgid
Photo of Hashimi

Hashimi

  • 642 Posts
  • 40 Reply Likes
Hi Bridgid,

Here is the alternative Fetch Endpoint - Developing Visualforce Page to Show Associated JIRA Issues in Salesforce Case. You can customise the result as well by using the code.

Thanks,
Hashimi